Daily Shaarli

All links of one day in a single page.

September 25, 2026

Le jardin - Accueil
Blog Stéphane Bortzmeyer: RFC 10050: Protocol-Specific Profiles for JSContact

La solution de notre RFC est de permettre la définition de profils, un profil étant une définition de ce qui est nécessaire dans un objet JSContact. Ainsi, une application qui n'a besoin que de peu de données peut utiliser JSContact au lieu de définir son propre format. Le registre central permettra de trouver et de référencer facilement les profils. (Aujourd'hui, aucun n'est enregistré.)

JSContact vise à remplacer vCard (RFC 6350) et sa déclinaison jCard (RFC 7095), complexes et difficiles à traiter.

Ce RFC normalise des profiles en JSContact, afin qu'une application utiliser JSContact au lieu de définir son propre format de données.

Un profil est donc un ensemble d'élements JSContact, stocké dans le registre IANA.

The root scroller and how not to lose it | Polypane
Buy Fonts — Regret Nothing — fonts.xyz

fonts.xyz is our little internet village for independent type foundries and designers. We bring creators together with free, easy-to-use tools so they can spend less time wrestling websites and more time doing the important stuff: making, finding, and obsessing over the perfect fonts.

SourceHut account takeover via build logs (XSS in ansi2html.py) | CVE-2026-92973 | Arusekk blog

A wormable vulnerability allowed anyone able to inject text in a build log on builds.sr.ht (or other instances) to take over accounts who viewed them

Playing with state | Sarah Higley

Change the name, but not the state, of play/pause buttons. Use state for all other toggle buttons.

As a final note, never change both the name and aria-pressed state in tandem. That way, confusion lies. Just imagine trying to parse the meaning of "play button, on" vs. "pause button, off".

La régie publicitaire de SNCF Connect | SNCF Connect

Ouch, ils vendent donc les données des clients, et confirment afficher des publicités.

It’s about time I tried to explain what progressive enhancement actually is - Piccalilli

Graceful degradation is the opposite to progressive enhancement because a pre-determined “perfect experience” is authored then broken down with support testing strategies instead. The problem with that approach is everything can and will go wrong in the browser, so support testing strategies will unlikely never be reached in a lot of cases, which results in a broken, unresponsive user interface.

The final deliverable of a web-based design is on the web, just like the final deliverable of a print design is print. Instead of handing off, designers and developers need to work in collaboration with each other in design implementation with a culture of flexibility.

Ubuntu : un noyau toutes les deux semaines pour suivre la cadence des correctifs - Next

Pourquoi un tel changement ? Pour les mêmes raisons que dans les changements annoncés dans les rythmes de Chrome ou Firefox : tenir compte du déluge de corrections entrainé par l’utilisation des LLM dans la recherche de failles. On voit depuis plusieurs mois une explosion des correctifs, par exemple chez Mozilla (qui a bénéficié de Mythos 5 d’Anthropic, via Glasswing), ou encore chez Microsoft et son infrastructure Perception.

La cadence des publications s'intensifie afin de corriger les failles de sécurité.

Fin août, Greg Kroah-Hartman, mainteneur principal du noyau, relevait qu’une version du noyau corrigeait en moyenne 500 vulnérabilités (CVE) entre les moutures 6.9 et 6.19. Mais la version 7.0 en a corrigé plus de 1 000 et la 7.2 a dépassé les 1 500. À ce rythme, le noyau 7.3 pourrait passer la barre des 2 000.

Do your employees actually use your product? - Frank DENIS random thoughts.

The most innovative and productive companies I’ve worked with had something in common: employees used the company’s products because they wanted to.

That willingness to use the product tells me more about a company than the size of its budget.

A company can hire excellent people and have a convincing plan for the future. But neither guarantees that anyone there will choose the product when they have a choice.

So when I think about what helps a company come up with useful improvements, one of the first things I’d look at is whether its employees choose to use what they’re building.

“AI, make the website good”—zachleat.com

The AI websites are actually pretty slow, so does SPAs and the instability of big actors recently (GitHub)

Patrick - Blurry before beautiful: image previews for the web

Blurhash again :)

The author suggest a new previewsrc attribute to replace blurhash.

Pure Commons

Minimalistic tools (plain file or SQLite databases) focused on one core job well done, stability and privacy. They build an ecosystem.

Nouvelles extensions Internet : 1 616 demandes payées, joyeux Hunger Games à tous - Next

Les TLDs sont vraiment un business.